Email delay/failures - Microsoft

Incident Report for Impac Risk Manager

Resolved

The intermittent delays for certain email services issue is now resolved, and delivery functionality is running as expected.
Posted Aug 19, 2026 - 10:52 NZST

Investigating

We are currently experiencing intermittent delivery delays or failures for emails sent to Microsoft 365, Outlook, Hotmail, and related addresses. This is due to a widespread issue affecting multiple email providers, including ours, and is not specific to our service.
We are actively monitoring the situation and working with our email delivery partner to resolve it as quickly as possible. Most other email providers (Gmail, Yahoo, etc.) remain unaffected.
We apologise for any inconvenience and will update this page once normal delivery resumes.
Posted Aug 17, 2026 - 13:33 NZST
This incident affected: Risk Manager.